Link rot

A few years ago I wrote a post about using Windows Speech Recoginition. One of the issues I had was that it did not play well with Firefox. After lots of googling I found the solution and posted the link to it in my post:

Windows Speech Recognition

Unfortunately that link no longer works as the site no longer exists. Thankfully I was able to retrieve the original content from the Internet Archive:

https://web.archive.org/web/20131010082540/http://speechcomputing.com/node/2720

However, I also posted the link to a forum over on Overclockers to someone who had the exact same problem as me:

http://www.overclock.net/t/595697/windows-speech-recognition-slow-ff/10#post_11922022

Now there’s someone else asking for the solution and the link no longer works! I should have posted the solution directly in the forum and referenced the source with the link. So I’ve gone back and done that and will also post the solution here in another post.

Moral of the story: always give answers directly on the site the questions are asked on as you never know when links might break!

But never hide your sources. Don’t take credit for someone else’s work.

Advertisements

One comment

  1. […] my previous post about link rot I lamented the fact that a post I made on a forum was no longer helpful as I only […]

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: